I am running iOS 10 and I am not able to install the current version of Duo mobile from the App Store on my device.

The minimum supported operating system version for Duo mobile 3.29.0 and above is iOS 11. 

iOS 10 users may download the last Duo mobile version compatible with that iOS version (3.28.1) via Apple's TestFlight program. 

  1. You'll need to install the Apple TestFlight application on your device. 
  2. Once you have TestFlight installed, tap this link and then tap Install to install Duo Mobile 3.28.1 on your iOS 10 device. 

Contact the IT Support center at 713-743-1411 or via Live Chat if further assistance is required. 

Created: Jul 28, 2020 - 8:1am Updated: Aug 18, 2020 - 11:22am Author: UIT Support Center Article: 3093
Was this article helpful?

Thank you for your feedback. Click Here to submit again.